using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^A{3}\/([A-Z]{0,8})\/A{3}$";
string input = @"AAA/BBCCDDFF/AAA
AAA/BB/AAA
AAA//AAA";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}