// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^A{3}\/([A-Z]{0,8})\/A{3}$").unwrap();
let string = "AAA/BBCCDDFF/AAA
AAA/BB/AAA
AAA//AAA";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}