$re = '/^A{3}\/([A-Z]{0,8})\/A{3}$/m';
$str = 'AAA/BBCCDDFF/AAA
AAA/BB/AAA
AAA//AAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);