package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^A{3}\/([A-Z]{0,8})\/A{3}$`)
var str = `AAA/BBCCDDFF/AAA
AAA/BB/AAA
AAA//AAA`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}