using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<a1>\d{10})_(?<a2>\d{10})_(?<a3>\D{4})_(?<a4>\d{2}).(?<a5>\d{2}).(?<a6>\d{4})_(?<a7>\D{2})_(?<a8>\d{2}).(?<a9>\d{2}).(?<a10>\d{4})_(?<a11>\d{3})_(?<a12>\d+).(?<a13>\D{3})";
string input = @"2016000009_0002583207_From_04.01.2016_To_04.01.2016_001_1.PDF";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}