use strict;
my $str = '2016000009_0002583207_From_04.01.2016_To_04.01.2016_001_1.PDF';
my $regex = qr/(?<a1>\d{10})_(?<a2>\d{10})_(?<a3>\D{4})_(?<a4>\d{2}).(?<a5>\d{2}).(?<a6>\d{4})_(?<a7>\D{2})_(?<a8>\d{2}).(?<a9>\d{2}).(?<a10>\d{4})_(?<a11>\d{3})_(?<a12>\d+).(?<a13>\D{3})/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}