import Foundation
let pattern = #"(?<a1>\d{10})_(?<a2>\d{10})_(?<a3>\D{4})_(?<a4>\d{2}).(?<a5>\d{2}).(?<a6>\d{4})_(?<a7>\D{2})_(?<a8>\d{2}).(?<a9>\d{2}).(?<a10>\d{4})_(?<a11>\d{3})_(?<a12>\d+).(?<a13>\D{3})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"2016000009_0002583207_From_04.01.2016_To_04.01.2016_001_1.PDF"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}