package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(b.*?)?apple`)
var str = `>Matched
dolphin elephant apple star
dog cat apple banana
>Unmatched
map banana apple dog
>Only the first apple matched, others are unmatched.
map apple banana apple cat
map apple banana apple banana apple
>The first apple and the second apple matched, others are unmatched.
map apple dog apple banana apple banana apple
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}