import Foundation
let pattern = #"(b.*?)?apple"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
>Matched
dolphin elephant apple star
dog cat apple banana
>Unmatched
map banana apple dog
>Only the first apple matched, others are unmatched.
map apple banana apple cat
map apple banana apple banana apple
>The first apple and the second apple matched, others are unmatched.
map apple dog apple banana apple banana apple
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)