$re = '/(b.*?)?apple/';
$str = '>Matched
dolphin elephant apple star
dog cat apple banana
>Unmatched
map banana apple dog
>Only the first apple matched, others are unmatched.
map apple banana apple cat
map apple banana apple banana apple
>The first apple and the second apple matched, others are unmatched.
map apple dog apple banana apple banana apple
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);