# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(b.*?)?apple"
test_str = (">Matched\n"
"dolphin elephant apple star\n"
"dog cat apple banana\n\n"
">Unmatched\n"
"map banana apple dog\n\n"
">Only the first apple matched, others are unmatched.\n"
"map apple banana apple cat\n"
"map apple banana apple banana apple\n\n"
">The first apple and the second apple matched, others are unmatched.\n"
"map apple dog apple banana apple banana apple\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.