#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[A-Z][a-zA-Z0-9])\/[A-Z].+$"
Local $sString = "aa/xx/Ab/Cd" & @CRLF & _
"bb/yy/zz/Ef" & @CRLF & _
"aa/aa/aa/AA" & @CRLF & _
"bb/bb/BB/AA" & @CRLF & _
"df/sd/sfA/Rg" & @CRLF & _
"aa/xx/Abc/Def <- fail"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")