import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[A-Z][a-zA-Z0-9])\\/[A-Z].+$";
final String string = "aa/xx/Ab/Cd\n"
+ "bb/yy/zz/Ef\n"
+ "aa/aa/aa/AA\n"
+ "bb/bb/BB/AA\n"
+ "df/sd/sfA/Rg\n"
+ "aa/xx/Abc/Def <- fail";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}