$re = '/(?<=[A-Z][a-zA-Z0-9])\/[A-Z].+$/m';
$str = 'aa/xx/Ab/Cd
bb/yy/zz/Ef
aa/aa/aa/AA
bb/bb/BB/AA
df/sd/sfA/Rg
aa/xx/Abc/Def <- fail';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);