re = /(?<=[A-Z][a-zA-Z0-9])\/[A-Z].+$/m
str = 'aa/xx/Ab/Cd
bb/yy/zz/Ef
aa/aa/aa/AA
bb/bb/BB/AA
df/sd/sfA/Rg
aa/xx/Abc/Def <- fail'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end