re = /(?i)\b([n🇳]|(\/\/)|(\/\|\/)|(\/\\\/)|(\|\\\|))+[îi1ÌĮĪÍÏl]+[gb96][gb96]+(er|a)+s?\b/m
str = '//igger /|/igger /\\/igger |\\|igger nigger'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end