package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(f(.*)?(\s)?o(.*)?(\s)?r(.*)?(\s)?t(.*)?(\s)?n(.*)?(\s)?i(.*)?(\s)?t(.*)?(\s)?e)`)
var str = `fbjrehfdlkjsfortnitesfdsojfoidsjkclnvklnFortnitebjbsvhfsdulfd
F O R T N I T E
Fgfdg
Ofdsgfdsg
Rfsdgfdsgf
Tdsgfsdgf
Nsdgfsdgf
Idsgfsdgfds
Tfsdgfdgf
Esgfsgfsd
FOOOOOORRRRRRTTTTTNNNNIIIIITTTTTTEEEEEE
F.O.R.T.N.I.T.E
// In the original string before the regex check, leet speak numbers can be replaced with letters.
f0rtn1t3
// After writing the "comment" above, I found that it matched "Fornite" in it and realized the monster I had created.
// Please help me.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}