use strict;
my $str = 'fbjrehfdlkjsfortnitesfdsojfoidsjkclnvklnFortnitebjbsvhfsdulfd
F O R T N I T E
Fgfdg
Ofdsgfdsg
Rfsdgfdsgf
Tdsgfsdgf
Nsdgfsdgf
Idsgfsdgfds
Tfsdgfdgf
Esgfsgfsd
FOOOOOORRRRRRTTTTTNNNNIIIIITTTTTTEEEEEE
F.O.R.T.N.I.T.E
// In the original string before the regex check, leet speak numbers can be replaced with letters.
f0rtn1t3
// After writing the "comment" above, I found that it matched "Fornite" in it and realized the monster I had created.
// Please help me.';
my $regex = qr/(?i)(f(.*)?(\s)?o(.*)?(\s)?r(.*)?(\s)?t(.*)?(\s)?n(.*)?(\s)?i(.*)?(\s)?t(.*)?(\s)?e)/mp;
if ( $str =~ /$regex/g ) {
  print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
  # print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
  # print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}