re = /(?i)(f(.*)?(\s)?o(.*)?(\s)?r(.*)?(\s)?t(.*)?(\s)?n(.*)?(\s)?i(.*)?(\s)?t(.*)?(\s)?e)/m
str = 'fbjrehfdlkjsfortnitesfdsojfoidsjkclnvklnFortnitebjbsvhfsdulfd
F O R T N I T E
Fgfdg
Ofdsgfdsg
Rfsdgfdsgf
Tdsgfsdgf
Nsdgfsdgf
Idsgfsdgfds
Tfsdgfdgf
Esgfsgfsd
FOOOOOORRRRRRTTTTTNNNNIIIIITTTTTTEEEEEE
F.O.R.T.N.I.T.E
// In the original string before the regex check, leet speak numbers can be replaced with letters.
f0rtn1t3
// After writing the "comment" above, I found that it matched "Fornite" in it and realized the monster I had created.
// Please help me.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end