import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[NUM]\\s*(?:hour|minute|time)s?\\b|!|\\?{2}";
final String string = "Is it possible to apply [NUM] times\n"
+ "Is it possible to apply [NUM] time\n"
+ "Called [NUM] hour ago\n"
+ "waited [NUM] hours\n"
+ "waiting [NUM] minute\n"
+ "waiting [NUM] minutes???\n"
+ "Are you kidding me !\n"
+ "Waiting?";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}