import re
regex = re.compile(r"\[NUM]\s*(?:hour|minute|time)s?\b|!|\?{2}", flags=re.MULTILINE)
test_str = ("Is it possible to apply [NUM] times\n"
"Is it possible to apply [NUM] time\n"
"Called [NUM] hour ago\n"
"waited [NUM] hours\n"
"waiting [NUM] minute\n"
"waiting [NUM] minutes???\n"
"Are you kidding me !\n"
"Waiting?")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")