re = /\[NUM]\s*(?:hour|minute|time)s?\b|!|\?{2}/m
str = 'Is it possible to apply [NUM] times
Is it possible to apply [NUM] time
Called [NUM] hour ago
waited [NUM] hours
waiting [NUM] minute
waiting [NUM] minutes???
Are you kidding me !
Waiting?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end