using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<!-- s(\S*) --><img src=""\S*"" alt=""\S*"" title=""[^""]+"" \/><!-- s\S* -->)";
string input = @"<!-- s:D --><img src=""{SMILIES_PATH}/icon_biggrin.gif"" alt="":D"" title=""Very Happy"" /><!-- s:D --> <!-- scat --><img src=""{SMILIES_PATH}/cat2.gif"" alt=""cat"" title=""Cat"" /><!-- scat -->";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}