import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<!-- s(\\S*) --><img src=\"\\S*\" alt=\"\\S*\" title=\"[^\"]+\" \\/><!-- s\\S* -->)";
final String string = "<!-- s:D --><img src=\"{SMILIES_PATH}/icon_biggrin.gif\" alt=\":D\" title=\"Very Happy\" /><!-- s:D --> <!-- scat --><img src=\"{SMILIES_PATH}/cat2.gif\" alt=\"cat\" title=\"Cat\" /><!-- scat -->";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}