package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<!-- s(\S*) --><img src="\S*" alt="\S*" title="[^"]+" \/><!-- s\S* -->)`)
var str = `<!-- s:D --><img src="{SMILIES_PATH}/icon_biggrin.gif" alt=":D" title="Very Happy" /><!-- s:D --> <!-- scat --><img src="{SMILIES_PATH}/cat2.gif" alt="cat" title="Cat" /><!-- scat -->`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}