using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\/\/)\s*define\s*\(\s*([\'""])WP_CACHE\1\s*,\s*(?:\-?[1-9][0-9\.]*|TRUE|([\'""])(?:[^0\'""]|[^\'""]{2,})\2)\s*\)\s*";
string substitution = @"";
string input = @"//define('WP_CACHE', true); //Added by WP-Cache Manager";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}