import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!\\/\\/)\\s*define\\s*\\(\\s*([\\'\"])WP_CACHE\\1\\s*,\\s*(?:\\-?[1-9][0-9\\.]*|TRUE|([\\'\"])(?:[^0\\'\"]|[^\\'\"]{2,})\\2)\\s*\\)\\s*";
final String string = "//define('WP_CACHE', true); //Added by WP-Cache Manager";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}