$re = '/(?<!\/\/)\s*define\s*\(\s*([\'"])WP_CACHE\1\s*,\s*(?:\-?[1-9][0-9\.]*|TRUE|([\'"])(?:[^0\'"]|[^\'"]{2,})\2)\s*\)\s*/i';
$str = '//define(\'WP_CACHE\', true); //Added by WP-Cache Manager';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;