use strict;
my $str = '//define(\'WP_CACHE\', true); //Added by WP-Cache Manager';
my $regex = qr/(?<!\/\/)\s*define\s*\(\s*([\'"])WP_CACHE\1\s*,\s*(?:\-?[1-9][0-9\.]*|TRUE|([\'"])(?:[^0\'"]|[^\'"]{2,})\2)\s*\)\s*/ip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";