using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"('\w+'\s*).*?(?=[,\]])";
string substitution = @"$1";
string input = @"['name' {d763e18f-1719-480b-bcd6-8fea7bad894e} Parameter, 'class' {8471633e-4a54-4c86-bd2b-56d58baf2fbb} Parameter, 'id' {23471633e-4a54-4c86-bd2b-56d58baf2fbb} Parameter]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}