$re = '/(\'\w+\'\s*).*?(?=[,\]])/';
$str = '[\'name\' {d763e18f-1719-480b-bcd6-8fea7bad894e} Parameter, \'class\' {8471633e-4a54-4c86-bd2b-56d58baf2fbb} Parameter, \'id\' {23471633e-4a54-4c86-bd2b-56d58baf2fbb} Parameter]';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;