const regex = /(["'])((?:(?=(\\?))\3.)*?)\1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(["\'])((?:(?=(\\\\?))\\3.)*?)\\1', 'g')
const str = ` HYPERLINK "hyperlink_funda.docx" \\l "Sales"`;
const subst = `$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);