import Foundation
let pattern = #"(["'])((?:(?=(\\?))\3.)*?)\1"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #" HYPERLINK "hyperlink_funda.docx" \l "Sales""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)