$re = '/(["\'])((?:(?=(\\\\?))\3.)*?)\1/';
$str = ' HYPERLINK "hyperlink_funda.docx" \\l "Sales"';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;