use strict;
my $str = ' HYPERLINK "hyperlink_funda.docx" \\l "Sales"';
my $regex = qr/(["'])((?:(?=(\\?))\3.)*?)\1/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";