#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)休憩\D{0,10}(\d*\.\d?|\d+)"
Local $sString = "休憩時間11.4時間" & @CRLF & _
"休憩 4 時間" & @CRLF & _
"休憩時間:0.05" & @CRLF & _
"休憩:0." & @CRLF & _
"休憩時間:0.2" & @CRLF & _
"休憩:11.52" & @CRLF & _
"休憩タイム 2時間" & @CRLF & _
"休憩時間: 0 時間" & @CRLF & _
"やすみ 4時間" & @CRLF & _
"休憩:なし 携帯 90" & @CRLF & _
"休憩と十日有休をくれ 2時間"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")