const regex = /休憩\D{0,10}(\d*\.\d?|\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('休憩\\D{0,10}(\\d*\\.\\d?|\\d+)', 'gm')
const str = `休憩時間11.4時間
休憩 4 時間
休憩時間:0.05
休憩:0.
休憩時間:0.2
休憩:11.52
休憩タイム 2時間
休憩時間: 0 時間
やすみ 4時間
休憩:なし 携帯 90
休憩と十日有休をくれ 2時間`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}