$re = '/休憩\D{0,10}(\d*\.\d?|\d+)/m';
$str = '休憩時間11.4時間
休憩 4 時間
休憩時間:0.05
休憩:0.
休憩時間:0.2
休憩:11.52
休憩タイム 2時間
休憩時間: 0 時間
やすみ 4時間
休憩:なし 携帯 90
休憩と十日有休をくれ 2時間';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);