// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)休憩\D{0,10}(\d*\.\d?|\d+)").unwrap();
let string = "休憩時間11.4時間
休憩 4 時間
休憩時間:0.05
休憩:0.
休憩時間:0.2
休憩:11.52
休憩タイム 2時間
休憩時間: 0 時間
やすみ 4時間
休憩:なし 携帯 90
休憩と十日有休をくれ 2時間";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}