package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`259(38|46|80|92|9[6-9])`)
var str = `25997`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}