const regex = /259(38|46|80|92|9[6-9])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('259(38|46|80|92|9[6-9])', '')
const str = `25997`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}