using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?:(?!input)[^>])*>(?:<\/[^>]*>)?";
string input = @"<input type=""text"">
<img src="">
<a href="">
<button type=""button""></button>
<div id=""some""></div>
<p></p>
<inputasd>
<inputasd";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}