import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(?:(?!input)[^>])*>(?:<\\/[^>]*>)?";
final String string = "<input type=\"text\">\n"
+ "<img src=\">\n"
+ "<a href=\"\">\n"
+ "<button type=\"button\"></button>\n"
+ "<div id=\"some\"></div>\n"
+ "<p></p>\n"
+ "<inputasd>\n"
+ "<inputasd";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}