re = /<(?:(?!input)[^>])*>(?:<\/[^>]*>)?/im
str = '<input type="text">
<img src=">
<a href="">
<button type="button"></button>
<div id="some"></div>
<p></p>
<inputasd>
<inputasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end