$re = '/<(?:(?!input)[^>])*>(?:<\/[^>]*>)?/im';
$str = '<input type="text">
<img src=">
<a href="">
<button type="button"></button>
<div id="some"></div>
<p></p>
<inputasd>
<inputasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);