# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\S*undefined\S*//gi;t' <<< "hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined"