package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\S*undefined\S*`)
var str = `hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}