$re = '/\S*undefined\S*/i';
$str = 'hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;