using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\S*undefined\S*";
string substitution = @"";
string input = @"hello my number is 344undefined848 undefinedundefined undefinedcalling whistleundefined";
RegexOptions options = RegexOptions.IgnoreCase;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}