import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<br />(.+?)ar />";
final String string = "SMPN 2 Aesesa Selatan<br />SMPN 2 Aesesa Selatan<br />Desa/Kel. Lange Dhawe<br />Kec. Aesesa Selatan<br />Kab. Nagekeo<ar />Nusa Tenggara Timur<br />Type : USB<br />Progress : COMPLETED";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}